PHP8.1

Jetzt wechseln auf PHP 8.1

Bereits im November 2021 ist die neuste Version von PHP erschienen. Mit PHP 8.1 wurden wieder viele neue Funktionen veröffentlicht. Wie bereits in früheren Versionen von PHP verbessern sich Leistung und Geschwindigkeit. Zu den Neuerungen der aktuellen PHP-Version zählen unter anderem der neue Aufzählungstyp Enum, sowie asynchrone Funktionen. Seit Anfang des Jahres kann PHP 8.1 auch auf unseren Servern genutzt werden. Bestehende Webseiten können in unserem Kundencenter bequem auf die neueste PHP-Version umgeschaltet werden. Neue Domains werden automatisch mit PHP 8.1 angelegt.

Nutzen Sie noch eine alte PHP-Version?

Neue Software-Versionen bringen auch das Ende alter Versionen mit sich. So wird am 28.11.2022 der erweiterte Support für PHP 7.4 und am 26.11.2023 der Support für PHP 8 auslaufen. Ab diesem Zeitpunkt wird es keine neuen Sicherheitsupdates für PHP 7.4 und PHP 8 mehr geben, so dass wir gezwungen sein werden, alle Webpräsenzen auf eine neuere PHP-Version umzustellen. Damit Sie sicher gehen können, dass Ihre Webseite auch nach der Umstellung noch funktioniert, empfehlen wir Ihnen, Ihre Webseite schon jetzt zu testen.

Wie Sie schnell und einfach auf die neuste Version wechseln können

Um Ihre Webseite umzustellen melden Sie sich einfach in unserem Kundencenter an. Dieses erreichen Sie über den Link Kundencenter oben rechts auf unserer Homepage. Im Kundencenter wählen Sie bitte den zu ändernden Webhosting-Vertrag aus und gehen auf Domains. Im unteren Bereich der Seite im Kasten Ziele sind die Hosting-Verzeichnisse mit ihrer jeweiligen aktiven PHP-Version aufgeführt. Klicken Sie auf das Stiftsymbol des Verzeichnisses, für welches Sie die Einstellung ändern möchten. Auf der folgenden Seite können Sie zwischen den verschiedenen PHP-Versionen auswählen.

Falls Sie Fehler in der Anzeige feststellen sollten, führen Sie bitte zuerst ein Update ihrer Webanwendung durch. Für die meisten bekannten Softwarepakete stehen aktualisierte Pakete zur Verfügung, welche zur aktuellen PHP-Version kompatibel sind.