phphant

PHP 7.4 – Wir unterstützen ab sofort die neueste Version

PHP verbessert sich weiter. Vor wenigen Tagen wurde die neueste Version PHP 7.4 mit vielen neuen Funktionen veröffentlicht. Wie bereits in früheren Versionen von PHP 7 verbessern sich Leistung und Geschwindigkeit. Durch die Möglichkeit, einfacheren Code zu schreiben, wird die Ausführung der Skripte beschleunigt und der Code wird sauberer.

Viele Wünsche der Softwareentwickler wurden durch die PHP-Verantwortlichen umgesetzt. Die Software wurde stetig verbessert, damit sie noch intuitiver, leichter nutzbar und funktionsstärker ist. Zu den neuen Funktionen gehören insbesondere die sogenannten "Arrow functions", Preloading, Typed Properties, sowie das neue "Foreign function interface" (FFI) mit dem es nun möglich ist, in C geschriebenen Code direkt aus PHP heraus aufzurufen.

Ab sofort kann PHP 7.4 auch auf unseren Servern genutzt werden. Bestehende Webseiten können in unserem Kundencenter bequem auf die neueste PHP-Version umgeschaltet werden. Neue Domains werden automatisch mit PHP 7.4 angelegt.

Supportende für PHP 7.2 und PHP 7.3

Neue Software-Versionen bringen auch das Ende alter Versionen mit sich. So wird am 30.11.2020 der erweiterte Support für PHP 7.2 und am 06.12.2021 die Unterstützung für PHP 7.3 auslaufen. Ab diesem Zeitpunkt wird es keine neuen Sicherheitsupdates für PHP 7.2 und PHP 7.3 mehr geben, so dass wir gezwungen sein werden, alle Webpräsenzen auf eine neuere PHP-Version umzustellen.

Um Ihre Webseite umzustellen melden Sie sich einfach in unserem Kundencenter an. Dieses erreichen Sie über den Link Kundencenter oben rechts auf unserer Homepage. Im Kundencenter wählen Sie bitte den zu ändernden Webhosting-Vertrag aus und gehen auf Domains. Im unteren Bereich der Seite im Kasten Ziele sind die Hosting-Verzeichnisse mit ihrer jeweiligen aktiven PHP-Version aufgeführt. Klicken Sie auf das Stiftsymbol des Verzeichnisses, für welches Sie die Einstellung ändern möchten. Auf der folgenden Seite können Sie zwischen den verschiedenen PHP-Versionen auswählen. Falls Sie Fehler in der Anzeige feststellen sollten, führen Sie bitte zuerst ein Update ihrer Webanwendung durch.

Für die meisten bekannten Softwarepakete stehen aktualisierte Pakete zur Verfügung, welche zur aktuellen PHP-Version kompatibel sind.

Schreiben Sie einen Kommentar

Ihre E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.